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Getting Started
To complete this tutorial, you need Boris Blue installed on your computer. If you have not 
already installed Boris Blue, you can do so by following the instructions in the Installation 
Guide that is included with your software.

To launch Boris Blue, double-click the Boris Blue icon. Boris Blue’s interface consists of four 
main elements: the Controls window, the Composite window, the Project window (not 
pictured) and the Timeline window. 
Controls window Composite window

Timeline window
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Animating a 3D Model Using Keyframes
In this tutorial, you will use keyframes to animate a single track in 3D space. This tutorial 
also covers basic interpolation settings and file management.

This tutorial uses media from PlanIT3d. To complete the tutorial you can use your own 
3D model or download the model used in the tutorial from www.PlanIT3d.com.

Importing a 3D Model

1. Launch Boris Blue. The Project tab of the Preferences window appears.

2. The Project menu should be set to the default, 720 x 486 NTSC D1. If it is not set to the 
default project size, choose it from the menu. If you work in PAL, choose 
720 x 576 PAL D1 DV from the menu.

3. Increase the Duration of your effect to 180 (frames).

4. (Optional) Deselect Show Options at Launch to prevent the Preferences window from 
appearing the next time that you launch Blue.

5. Click OK. The Blue interface appears.

6. In the Timeline window, click the Add Model button.
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7. A dialog box lets you navigate to the file’s 
location. Highlight the 3D model file and click 
Open. The image appears in the Composite 
window and tracks appear in the timeline.

8. Click the Visibility icon on the 
Imported Model track to hide that 
track. The taxi disappears from the 
Composite window.

9. Click the Visibility icon again to restore 
the taxi’s visibility.

Adding a Gradient Background
In this part of the tutorial we add a gradient background to make the effect more interesting.

1. In the Timeline window, click the Add Gradient Media button.

A Gradient track appears in the Timeline and gradient media appears in the 
Composite window.

2. Drag the Gradient track below the 
Imported Media track. This ensures that 
the gradient appears behind the 
imported model. Your tracks should 
look like the example at right. 

3. (Optional) Select the Material track 
nested in the Gradient track and adjust 
the gradient in the Controls window.

4. Click the disclosure triangle next to the 
Gradient track to hide the tracks nested within it. 

Visibility icon

Disclosure triangle
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Naming Tracks
By default, tracks are named by their media type. For example, if you change a track’s media 
to Still Image File, the track is automatically assigned the file name. However, once you 
explicitly name a track, the track retains that name, even if you change the track’s media 
type. 

1. Select the Imported Model track and choose Track > Rename Track.

2. Type “Taxi” and press Enter. The track 
is renamed “Taxi.” You can also rename 
the track using the following shortcut. 
Select the track and press Enter. Type 
“Taxi” and press Enter. 

Animating the 3D Model Shape
You can assign each track in the 
timeline one of nine 3D shapes by 
pressing the Shape icon for that track. 
Note that each shape has a different 
icon.

Selecting a track displays the 
parameters for that type of track in the Controls window. Parameters can be animated using 
keyframes. A keyframe sets specific parameter values for a track at a certain point in the 
timeline. When you place multiple keyframes on the timeline, the program interpolates, or 
computes intermediate values, between keyframe values. 

Blue includes two types of keyframes, master keyframes and parameter keyframes. Master 
keyframes appear on the Shape and Container tracks. Parameter keyframes appear on the 
Transformations tracks nested inside the Shape and Container tracks. You can associate 
multiple parameter keyframes with each master keyframe. When you create a parameter 
keyframe, the corresponding master keyframe is automatically created. In this section, you 
will set keyframes in the timeline to animate several parameters.

1. Click to select the Taxi track. The track already has keyframes placed at the start and 
end. Because both keyframes contain the default parameter values for the track, the 
effect is static (not animated).

Shape icon

KeyframesCurrent Time Indicator (CTI) Time Field
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2. Move the Current Time Indicator (CTI) to frame 20 (Time 00:00:00:20). The CTI 
determines which frame of the effect displays in the Composite window. As you move 
the CTI around the timeline, the Composite window updates to display the frame at the 
new CTI location. Because the taxi is a still image, all the frames are the same.

You can either drag the CTI to the new location or type the timecode of the new location 
in the Time field in the Timeline window and press Enter. Make sure that the first 
keyframe is not selected after you drag the CTI. Selected keyframes are red. To deselect 
a keyframe, click in the track on the right side of the timeline.

3. If it is not already displayed, click the Position tab in the Controls window.

4. Change the Scale X value to 150 by 
dragging the slider to the right. 
(The three Scale values are locked 
by default, so the Scale Y and 
Scale Z settings also update.) You 
can also scrub the numerical field 
or click the numerical field, type 
150, and press Enter.

A new keyframe is automatically created at frame 20, and the taxi image is scaled to 
150% of its original size. The keyframe uses the default interpolation, Ease In/Out.

5. Click to select the new keyframe at 
frame 20. Selected keyframes are red. 

6. Press the Interpolation field in the 
Scale X controls. Choose Hold from 
the menu. 

Numerical Field SliderLock

Interpolation Field
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7. In the Controls window, set Spin Y to 0 rotations, 180° by 
typing 180 and pressing Enter.

8. Press the Interpolation field in the Spin Y controls. 
Choose Hold from the menu. 

9. Return the CTI to the beginning of the effect, either by dragging the CTI to the 
beginning or by pressing the Home key.

10. Play the sequence by clicking the Play button in the Composite window or 
by pressing the Space bar. 

The taxi starts full size and facing outward, spins around and increases to 
150% size by frame 20, then holds at that size and orientation for the remainder of the 
effect. Playback loops until you press the Space bar or Play button again.

Now, you will add animation to move the taxi off-screen. 

11. Select the Taxi track.

12. You should see red, green and blue OpenGL interactors in your Composite window. If 
you don’t, press the G key or choose Preview > OpenGL Interactor > Show Interactor. 
The interactors should display arrows at their ends to indicate that you are in 
Translation mode. If they don’t, press the W key or choose Preview > OpenGL 
Interactor > Translation Interactor. 

13. Expand the Taxi track by clicking the disclosure triangle to the left of the track name, 
then expand the Transformations track. Expand the Position track to reveal tracks that 
correspond to each parameter in the Position tab in the Controls window. The 
keyframes you set earlier in the exercise appear in the Scale X, Scale Y, Scale Z and 
Spin Y tracks as shown in the following example.

14. Move the CTI to frame 20 (Time 00:00:00:20).

Rotations

Degrees

Disclosure 
triangle
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15. Select the Position X track, then choose Track > New Keyframe or type Control-N. A 
parameter keyframe appears in the Position X track at the CTI’s current position (Time 
00:00:00:20). Use the same steps to create a new keyframe at that point in the Position Y 
and Position Z tracks. Because the keyframes use Ease In/Out interpolation, they 
appear as an “X” in the timeline. Your timeline should now appear like the following 
illustration. 

16. Move the CTI to the last frame in your effect (Time 00:00:06:00) and click the final 
keyframe for the Taxi track. The keyframe turns red to show that it is selected. You may 
need to scroll up.

17. Click the green interactor in the Composite window. The green interactor moves the 
image on the Y-axis. Make sure you click the interactor and not the taxi image. The shaft 
of the interactor turns yellow to indicate that it is selected.

18. Drag the interactor down until the taxi goes offscreen. In the Controls window, the 
value for Position Y updates. Stop dragging at a Position Y value of approximately 
1500. 

Most likely you’ll need to reduce the size of the preview scale to drag the 
interactor as far as needed. Choose a smaller scale from the Scale menu located 
in the Composite window. 

19. Click the red interactor and drag to the left until the taxi image is offscreen. Make sure 
you click the interactor and not the taxi image. The shaft of the interactor turns yellow 
to indicate that it is selected. In the Controls window, the value for Position X updates. 
Stop dragging at a Position X value of approximately -600. 

20. Click the blue interactor and drag downward until the taxi image disappears. Make 
sure you click the interactor and not the taxi image. The shaft of the interactor turns 
yellow to indicate that it is selected. In the Controls window, the value for Position Z 
updates. Stop dragging at a Position Z value of approximately 15000. 
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21. If you prefer, you can adjust the 
parameters in the Controls window by 
setting Position X to -600, Position Y to 
1500, and Position Z to 15000 with the 
default Ease In/Out interpolation. 

22. Return the CTI to the beginning of the 
effect, and play the effect. The taxi now spins around and increases to 150% size by 
frame 20, and moves off screen by frame 180.

Time 00:00:00:00 Time 00:00:00:20 Time 00:00:02:00

23. Complete the steps in the next section to finetune your animation.

Working with Bézier Curves
The Ease In/Out interpolation (the default interpolation type) allows you to work with 
bézier curves to finetune the motion of the effect. Keyframes that use the Ease In/Out 
interpolation are displayed as an “X” in the timeline. This section describes two ways of 
using the bézier controls to smooth transitions at keyframe points.

1. In the timeline, select the keyframe at frame 20 (Time 00:00:00:20). 

2. Expand the Position X track to reveal the Value curve controls for that parameter.
Value curve controls Value curveBézier handle
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Red bézier curve handles appear at each keyframe point on the Value curve in the 
timeline. 

If you do not see bézier handles in the value curve, press the interpolation field in 
the Position X controls and choose Ease In/Out from the menu.

3. Drag either of the handles to move them up or down or 
lengthen them. The left handle controls the curve going 
into the keyframe, and the right handle controls the curve 
going out of the keyframe.

4. To manipulate the direction of each bézier handle 
independently, press the Alt key as you drag the handle.

5. After adjusting the bézier handles, play your effect to see 
the affect of the adjustments.

An Introduction to Shaders
Shaders simulate different types of surfaces on each face of your 3D shape. Shaders calculate 
effects on a per-pixel basis, allowing you to create complex, realistic scenes in real time. 
Shaders provide unprecedented control for determining the lighting, shading, and color of 
each individual pixel, allowing you to create unique surface effects. 

In this example, you apply an Image Processor Shader to the 3D Container track in your 
effect.

1. Select the 3D Container track in your 
timeline. 

2. Choose Shaders > Image Processors > 
Invert Solarize.

The Shader is applied and the Composite 
window updates. An Invert Solarize Image 
Processor track appears in the timeline.

3. Play your effect. The Shader does not need to 
be rendered.

4. In the Controls window, choose 
Invert/Solarize Saturation from the Type 
menu.

Bézier handle
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Your effect updates with an altered Shader. Experiment with some of the other menu 
choices.

5. Boris Blue also makes it easy to change 
to a different Shader. Simply click the 
Shader icon to choose a different Shader 
from the menu. In the following 
example, a Scan Lines Shader has 
replaced the Invert Solarize Shader.

6. Again, experiment with different 
Shaders and make changes to them in the 
Controls window. 

Saving Settings
Use the Render Queue to render your effect. You can also save the settings file and open it 
later in a host application to render it. In this case, you will save the effect you created to the 
Project window and also in the Boris Library Browser so that you can reuse it later.

The Project window is useful if you want to experiment with multiple versions of an effect. 
You can save the composition to the Project window and then continue adjusting 
parameters. Later, if you decide that you like the earlier version, you can open that version 
in the timeline.

1. Choose Composition > Save Composition Copy.

A copy of your effect appears in the Project window.

Shader icon
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2. Click the Composition copy and rename it “First Effect” by pressing Enter, typing the 
name and pressing Enter again. When you finish, your Project window should look like 
the following example.

3. Choose File > Save Project Copy to Library.

A dialog box lets you name and save a copy of the effect. 

4. Click the New Folder button to create a new folder. Name the folder “My Effects” and 
press Enter.

5. Open the “My Effects” folder.

6. Click to select the With Thumbnail Previews checkbox.

7. Name your effect and click Save.




