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Understanding OpenGL
This document provides an overview of the OpenGL implementation in Boris Blue.

About OpenGL
OpenGL is a cross-platform standard for 3D acceleration. “GL” stands for “graphics 
library.” “Open” refers to the ongoing, industry-wide contributions to its evolution. 
OpenGL has been common in graphics workstations since 1992, and is built into both the 
Windows and Macintosh operating systems as well as a wide variety of display cards. 
However, OpenGL has only recently begun to make its way into video production. Boris 
Blue leverages the power of NVIDIA’s Graphics Processing Unit (GPU) cards to provide 
OpenGL hardware-based preview and rendering. 

The technology behind OpenGL grew out of the desire to display high-quality 3D images 
as quickly as possible. Specific instructions for drawing geometry, textures, lighting, and 
special effects have been coded into the chips powering many graphics applications, 
including game consoles, and many desktop computer display cards.

More details about OpenGL are available from www.opengl.org.

OpenGL and Boris Blue
The bottom line is speed. Boris Blue uses OpenGL to accelerate the rendering of 2D and 3D 
graphics. In many cases, animations display even faster than real time. That’s because the 
images are displayed using software embedded in display hardware optimized especially 
for this task. 

Supported OpenGL Cards

Boris Blue takes full advantage of the benefits offered by OpenGL and therefore has strict 
hardware and software requirements. Only NVIDIA-based cards are supported. Boris Blue 
supports the following cards:

•   GeForce (6800 and 7800-based cards)

•   Quadro (4000 and 4500-based cards)

Supported OpenGL Drivers

Boris Blue only supports the following drivers for the OpenGL card. Generally speaking, 
the latest drivers for Windows-compatible hardware are recommended, but be sure to check 
the Boris FX website for details. Please see www.borisfx.com/opengl for the latest updates 
to this information.

•   GeForce systems (6800 and 7800-based card) require driver version 77.77.

•   Quadro systems (4000 and 4500-based card) require driver version 77.56.
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The Difference Between Video Processing and OpenGL

Because the needs of 3D content creators are different than the needs of nonlinear video 
editors, OpenGL and desktop video take very different approaches to displaying images. 
Video systems are optimized to display fixed-size video images at a fixed rate. While some 
specialized effects hardware can perform real-time operations on video, video editors have 
also relied on components built into their computers to perform additional processing for 
special effects, such as CPUs and RAM.

OpenGL processing, on the other hand, is performed entirely on the OpenGL card. CPU 
power, including multiple CPUs, RAM, as well as dedicated video processors, including 
real-time effects hardware, do no affect OpenGL performance. While some OpenGL 
hardware has the ability to share excess processing tasks to fast computer memory, it is 
critical for video editors to understand that the hardware in their systems may not be 
equipped for OpenGL processing.

This is especially true of the hardware driving desktop computer monitors. Many computer 
display cards are designed to support large workspaces, but do not allocate any resources 
to drawing 3D objects, textures, or shading using OpenGL acceleration.

As a result, even the most current, state-of-the-art video systems may be missing the single 
component necessary to take advantage of OpenGL processing: the right display card. 
Fortunately, reasonably priced cards are available to support the OpenGL acceleration in 
Boris Blue. The same cards are generally supported by the handful of NLEs that support 
OpenGL, as well as other graphics and 3D applications.

Checking OpenGL Driver Versions
Prior to launching Boris Blue, make sure you have the correct driver installed for your card.

1. Right-click the Desktop and choose Properties from the menu that appears.

The Display Properties window appears.

2. Click the Settings tab.

3. Click the Advanced button.

The Properties window for your graphics card appears.
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4. Click the tab with the name of your card.

A second window appears on the left.

5. Select the name of your card in the window on the left.

6. Check the version of your card’s driver. It is listed under the heading, ForceWare 
version.

• GeForce systems (6800 and 7800-based card) require driver version 77.77.
• Quadro systems (4000 and 4500-based card) require driver version 77.56.

7. If the version is a supported version you can launch Blue. If the version is unsupported, 
download and install the correct version.

Downloading OpenGL Drivers
If your system does not have the required driver installed, you can download the driver 
from the following locations.

•   NVIDIA driver version 77.77 can be downloaded at: 
http://www.nvidia.com/object/winxp_2k_77.77.html

•   NVIDIA driver version 77.56 can be downloaded at: 
http://www.nvidia.com/object/winxp_2k_77.56.html

Driver 
version



 

4

 

  

 

 
• 
• 
•
•
•

                  
What are the requirements for OpenGL acceleration in Boris Blue?

When started for the first time after installation, Blue performs a fast, automatic test to look 
for the specific items. If your configuration passes this internal test, Blue opens. If your 
configuration does not pass, an error message will appear with more specific information. 
In that case, two thing s Blue will open with OpenGL off by default, but you may elect to 
enable it yourself. Please see the next section for more information on how to work with 
unqualified systems.

Clicking the Test OpenGL Hardware button in the Render tab of the Boris Blue Preferences 
window also shows the results of the internal test. This is the recommended method for 
examining your system’s configuration.

Available Texture Memory

Greater than 32 MB of texture memory must be available to Blue. As is typically the case 
with processing power, there’s no such thing as too much. More texture memory provides 
better performance, so if your budget allows a choice, go for the card with more texture 
memory.

The number we use in this context refers to the results of the OpenGL hardware test, rather 
than simply the amount of texture memory on your video card. For example, in some cases 
the Windows OS can make additional memory available, beyond what is installed on the 
card. 

Important Note on OpenGL Support

Due to the fast rate at which GL card manufacturers release drivers, Blue may disqualify 
your OpenGL driver erroneously. Boris FX will make every effort to continue to qualify 
OpenGL cards and driver versions. However, it is important to note that it is impossible to 
qualify all combinations of Open GL cards, operating system, and drivers.

Checking your OpenGL Hardware and Drivers in Boris Blue
The first time you launch Boris Blue, an internal test is run on your system to determine 
whether your hardware meets the minimum requirements necessary for OpenGL 
Hardware acceleration. 

1. Launch Boris Blue.

2. Choose Edit > Preferences.

3. Click the Preview tab. 

The Preview settings appear.
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4. Click the Test OpenGL Hardware button. A window appears with specifics of the 
OpenGL hardware and drivers that are installed on your system. 

5. If you want, click Yes to copy this information to your system clipboard. This allows 
you to print or E-mail this information. 
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OpenGL Errors
When the OpenGL Hardware Test is run, error messages may display if your system fails. 
These errors display as Critical errors or Soft errors. 

Certain errors are influenced by the display properties of your video card. The 
display property settings are card-driver specific. As a general rule, the display 
properties should be set to 32 bits of color, with the depth buffer set to at least 
16 bits. On many cards, the OpenGL capabilities are reduced when higher display 
resolution and refresh rates are set.

Critical Errors 

Critical OpenGL errors will not allow you to use OpenGL in Blue. When you receive a 
Critical error, OpenGL is automatically disabled when you launch Blue and cannot be 
enabled within the application. Critical errors include:

•   Initial malfunction in initiation of OpenGL indicates a basic hardware problem with 
the graphics board.

•   InadequateShaderSupport indicates the graphics board is missing basic features 
required by Blue.

•   UnsupportedManufacturer occurs when the graphics board is not NVIDIA-based.

•   UnsupportedHardwareModel occurs when the graphics board is not supported.

Soft Errors

Soft errors do not prevent you from using OpenGL, they just warn that your specific system 
and setup may cause problems with OpenGL. When you receive a Soft error, OpenGL is 
automatically disabled when you launch Blue. However, you can manually enable OpenGL 
in the Preview window or Preferences window. 

•   UnsupportedDriverVersion indicates an unsupported software driver.

•   InsufficientTextureMemory indicates a problem with the board’s VRAM.

•   InsufficientDepthResolution occurs when the computer’s display is set to 16-bit instead 
of 32-bit.

Enabling OpenGL
You can enable OpenGL in the Preview menu or in the Preferences window.

•   To enable OpenGL in the Blue Preference window, choose Edit > Preferences. Click the 
Preview Tab and choose Enabled from the OpenGL Acceleration menu.

•   To enable OpenGL in the Preview menu, choose Preview > OpenGL Mode and choose 
Enabled from the submenu.

When OpenGL is disabled, Blue runs in software-only mode. Almost all rendering is 
disabled in this mode and most objects will not appear in the Composite window. This 
mode is most useful as a troubleshooting tool.
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What are the difference between OpenGL playback and Preview to RAM?

OpenGL playback is engaged when pressing the spacebar to play while in Draft Quality. 
Preview to RAM is obviously slower, but offers more accurate display and timing, as well 
as the ability to include audio with your previews. (OpenGL is a visual format and doesn’t 
include audio at all). Be sure to switch back to High Quality for the RAM Preview.

Again note the fundamental difference between OpenGL processing and traditional CPU 
and RAM processing. OpenGL previews are handled entirely by the accelerated hardware 
on your display card; RAM previews go through the same path to your computer’s CPU as 
the final renders to disk. This is why RAM previews are slower on one hand, but more 
accurate on the other. The two kinds of previews provide two types of different tools, for 
two different tasks: speed and precision.

One more minor difference relates to the behavior of the Timeline window during previews. 
During RAM previews, rendered frames are marked in gray along the top of the window, 
and the CTI (Current Time Indicator) position updates to show playback progress. During 
OpenGL previews, no frames are rendered by the CPU, but rather by the graphics card, so 
no rendered frames are cached. It simply isn’t necessary, as OpenGL playback is faster than 
playback from frames cached in RAM. 

For similar reasons, the CTI does not update during OpenGL previews. The CTI is 
connected to CPU renders, and is not aware of OpenGL renders. Even if it were, OpenGL 
can display frames more quickly than the CTI could update. Tying the two together would 
slow down the OpenGL preview. Again note the difference between the purpose of 
previews in RAM and OpenGL, one to provide the most accurate possible previews, and the 
other to provide the fastest possible previews.

How do I use the OpenGL interactors in the Composite window?

The default interactors are for Translate, indicated by handles with arrows at the end. 
Mousing over one of the handles turns yellow to indicate that you can drag to constrain the 
movement of the selected object in that direction (X, Y or Z). Clicking the object, but not 
directly on the interactor, allows free movement in any direction.

Press the E key on your keyboard to switch the interactors to Rotate mode, indicated by 
spheres at the end of the handles. Again, dragging a handle constrains rotation to that axis, 
and clicking on the object, but not on the interactors, enables free rotation.

The R key enables Scale, indicated by squares at the end of the handles. 

W returns you to Translate mode, which is the default state of the interactors. G toggles the 
visibility of the interactors.

The W, E, R shortcuts for Translate, Rotate and Scale are standard in 3D modeling 
applications, but may also be changed using the customizable keyboard shortcuts feature in 
the Edit menu. The shortcuts for selecting these interactors are located in the Preview menu.

For more detailed information on using the OpenGL interactors, see Chapter 2 in 
Volume I of the Blue User Guide.
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Understanding Blue’s Real-Time Capabilities
Blue’s most powerful feature is the ability to adjust parameters with interactive real-time 
playback, including streaming video and audio. Blue’s OpenGL hardware acceleration 
provides this real-time playback. OpenGL is a cross-platform standard that dramatically 
improves the speed and interactivity of 2D and 3D previews.

Most, but not all, of Blue’s features are OpenGl hardware-accelerated. For example, all 
shaders are OpenGL hardware-accelerated. However, third-party After Effects filters do not 
take advantage of the OpenGL acceleration. In addition, media-level animations (such as an 
animated gradient or text on a path) are not accelerated.

You must work in Draft Quality to use Blue’s interactive real-time playback.

In certain circumstances, you may need to preview to RAM to ensure real-time playback 
without dropping frames. Preview to RAM may be required to preview complex effects or 
effects with multiple software-based filters.

Using the Draft Playback Mode
In certain circumstances, Blue may not be able to playback an effect in real-time 
without dropping frames. When you work in Draft mode, two options determine 
what happens when Blue cannot maintain real-time playback. To use these options, 
press the Quality button at the bottom of the Composite window and choose Draft quality. 

•   Choose Preview > Draft Playback Mode > Time Accurate to playback your effect in real 
time. Blue will drop frames as necessary to play the effect time-accurately. For example, 
a two-second effect will play for two seconds, but frames may be dropped to maintain 
playback. This is useful if you want a sense of your effect’s timing, but can tolerate a 
few dropped frames. Frames will not drop in your final render. 

•   Choose Preview > Draft Playback Mode > Frame Accurate to playback all frames in your 
effect. Blue plays all frames as close to real-time as possible. For example, a two-second 
effect could play back for two and a half seconds, but no frames would drop. This is 
useful if you need to see every frame to make sure that you like your animation.

•   If you need to playback all frames in your effect time-accurately and are experiencing 
dropped frames, choose Preview > Preview to RAM or type Control-0 to play effects in 
real time without rendering to disk. Your system plays as much of the effect as possible 
depending on your available memory. You do not have to be in Draft mode to use this 
option. This is useful if your effect includes multiple software filters, if you want to 
preview at High Quality to view anti-aliased vector shapes, or you want to preview all 
elements at High Quality before final render. For details on the Preview to RAM 
options, see Volume I of the Blue User Guide.

When you choose Preview to RAM, the effect plays slowly as Blue caches every 
frame. After the frames are cached, the effect plays in real time. Preview to RAM 
plays from the current position of the CTI. 
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Troubleshooting
My card is on the supported list, but an error message indicates that my card isn’t compatible.

This is almost certainly a driver issue. Be sure to check the Boris FX website for information 
on the latest supported drivers. In many cases, you’ll still be able to take advantage of 
OpenGL inside Boris Blue, as discussed earlier in this document.

Why do I see banding and reduced colors in the Composite window?

This can occur on Windows systems that have less than 32-bit color set in the Displays 
Control Panel. Boris Blue requires 32-bit color.

Why do I see white frames, purple frames, garbage frames and other distortions in the 
Composite window while trying to use OpenGL?

Your video card does not have enough texture memory to support the chosen level of 
OpenGL. Begin by reducing the amount of texture caching. If you still see problems, turn 
off texture caching, then turn off OpenGL if necessary, until you can upgrade your display 
card.

Why do OpenGL previews move more slowly with the Info window open?

Among the features of the Info window is that it measures the time it takes for an individual 
frame to be rendered by the computer’s CPU. OpenGL previews are not rendered by the 
CPU but by the graphics hardware. However, the Info window will force renders to the CPU 
in order to display that information, effectively bypassing the accelerated OpenGL preview 
in favor of the slower, but more accurate, CPU render.

One reason why the Info window is not currently an adequate measure of how quickly an 
individual frame is rendered is that OpenGL is frequently capable of displaying full 
resolution frames faster than 30 times per second, certainly faster than the calculation time 
can be displayed. In other words, showing the OpenGL processing time is much slower than 
the actual processing! 

Why is my OpenGL performance slower on my second monitor?

Windows users with dual head display cards have two options for configuring their 
displays: Independent and Stretched. In Independent mode, each screen runs 
independently of the other. It allows only one screen to support OpenGL playback, typically 
the monitor with the OS menu bar. In Stretched mode, the monitors share one display and 
one resolution, allowing OpenGL playback from any part of the display.

When working with a two monitor setup, Boris Blue requires that the Composite window 
be displayed on the Primary Display. If the Composite window is not displayed on the 
Primary Display, compositions will not appear correctly in the Composite window.

1. Right-click the Desktop and choose Properties from the menu that appears.

The Display Properties window appears.

2. Click the Settings tab.
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3. Click the Advanced button.

The Properties window for your graphics card appears. 

4. Click the tab with the name of your card.

A second window appears on the left.

5. Select nView Display Settings in the window on the left. This option only appears when 
two monitors are connected to your graphics card.

6. In the window on the right, select the monitor where your Composite window will 
appear and select the Make this the primary display checkbox.

7. Click OK and then click OK in the Display Properties window.
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