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Supported Host Applications
Red 4.3 adds support for latest Avid Media Composer and Symphony editing suites.  

Red 4 supports the following host applications.

Macintosh Windows
enignE deR siroBenignE deR siroB

Apple® Final Cut Pro HD® 5.0 or later

Adobe® Premiere Pro® 1.5, 2.0, and CS 3
CS 3Adobe® After Effects®CS 3Adobe® After Effects®

Avid AVX 1.5 API: 
Avid® Media Composer®, Avid Symphony® 
4.7, 4.8, 
Avid XpressMac®, Avid Xpress DV® 3.5.4, 
Avid Xpress Pro® 4.0 or later

Avid AVX 1.0 API: 
Avid|DS 6.0 through 7.6
Avid AVX 1.5 API: 
Avid® Media Composer®, Avid Symphony®, 
Avid Xpress Pro® 4.0 or later, Avid Xpress Studio, 

Avid Liquid® 7.0

Avid AVX 2.0 API: 
Avid Xpress Pro® 5.5 or later, 
Media Composer 2.5 or later, 
Avid Symphony Nitris 1.5.x
Avid Adrenaline Newscutter 6.5.x
Avid Media Composer 3
Avid Symphony 3

Avid AVX 2.0 API: 
Avid Xpress Pro® 5.5 or later, 
Media Composer 2.5 or later, 
Avid Media Composer 3 
Avid Symphony 3

Canopus® Edius 3 and 4.X

Harris Velocity

Media 100 i® 8.2.3a, Media 100 HD 11.x 
and Media 100 Producer 11.x 

Media 100® iFinish 4.6 
Media 100 844/x
Sony® Vegas® 7.0 
Sony® Vegas® 8.0

Apple® Final Cut Pro® 6.0 or later
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Notes on Using Boris Red

Using OpenGL
Due to the fast rate at which OpenGL card manufacturers release drivers, Boris Red may 
disqualify your OpenGL hardware erroneously. If this happens, you should try to enable 
OpenGL to see if you benefit from OpenGL acceleration. If you have troubles with slowness, 
or render inconsistencies, please disable OpenGL. For information on enabling OpenGL, see 
Enabling OpenGL.

While OpenGL may work in the Boris Red standalone, that does not necessarily mean it will 
work inside your host application. 

Boris Red is continually qualifying OpenGL cards and driver versions. However, it is important 
to note that it is impossible to qualify all combinations of OpenGL cards, operating system, 
drivers and host applications. In general you should run the latest supported driver available 
for your OpenGL card.

Configuring Dual Monitor Systems
On dual monitor systems, use the following instructions to correctly configure your video 
display board. Otherwise, system instability may result.

1. Right-click on the Desktop and choose Properties from the menu that appears.

The Display Properties window opens.

2. Click the Settings tab.

3. In the Settings tab, click the Advanced button.

4. Click the tab with the name of your card on it.
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The nView window appears.

1. On the left side of the window, select nView Display Settings.

2. On the right side of the window, choose Dualview from the nView Display Mode menu.

3. Next, on the left side of the window, select Performance & Quality Settings.

4. On the right side of the window, select 
Hardware acceleration from the Settings list.

5. Set the Hardware acceleration slider to Multi-
display compatibility mode, the middle 
setting.

6. Click the OK button.

7. Click OK in the Display Properties window.

Dual Monitor Limitations with OpenGL
Due to an issue with the NVidia card, Boris Red crashes if you are running the application on 
a dual monitor system with OpenGL. If you plan on using your Boris Red plug-in on a dual 
monitor system, you need to do one of the following:
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•   With OpenGL enabled, you must display the Composite window on the left-hand monitor.
•   If you want to display the Composite window on the right-hand monitor, you must disable 

OpenGL.
With OpenGL enabled:

•   The system default displays the Composite window on the left-hand monitor. If it’s on the 
right-hand monitor, click and drag the Composite window to the left-hand monitor.

To disable Open GL from the Preferences dialog box:

1. From Boris Red, select Edit > Preferences.

2. Click the Render tab.

3. From the OpenGL Acceleration menu, select Off.

You can then display the Composite window on the right-hand monitor.

To disable Open GL from the Preview menu:

•   From the Composite window, select Preview > OpenGL Mode > Off.
This disables OpenGL. You can then display the Composite window on the right-hand 
monitor.

Checking your OpenGL Hardware, Software, Drivers and Settings
The first time you launch Boris Red, an internal test is run on your system to determine 
whether your hardware meets the minimum requirements necessary for OpenGL Hardware 
acceleration. If your hardware does not meet the minimum requirements, OpenGL is 
disabled by default on your system. 

1. To perform the OpenGL Hardware test manually, click the Test OpenGL Hardware button 
in the Preferences window’s Render tab.

Depending on the amount of memory your graphics card has, this test may take a few 
minutes to run.

After the test is run, a window displays specifics of the hardware and drivers installed on 
your system which are necessary to run OpenGL. If any test results show your system 
may have problems running OpenGL, the errors are detailed in this window. 

2. If you want, click the Copy to Clipboard button to copy this information to your system 
clipboard. This allows you to print or e-mail this information. 

3. When you finish, click OK to close this window.
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Depending on your system, the test may take a few seconds to complete. The test 
stresses your OpenGL hardware, so you should run the test with a typical workload on 
your system. Before you run the OpenGL hardware test, open any graphics applications 
that you usually run while you edit (any graphics intensive applications you are running 
at the time may affect the results).

Boris Red uses the following guidelines for optimal OpenGL performance. Some of this 
information does not affect Boris Red’s hardware testing but is useful for technical support 
if you are having OpenGL problems:

•   Graphics Card - For information, go to www.borisfx.com.
•   OpenGL version - Should be 1.2 and higher.
•   Texture Rectangle - This is an advanced OpenGL image sizing feature. If you are having 

OpenGL problems, this provides useful information for technical support.
•   Texture Memory - Texture Memory displays the amount of memory on the video card 

available for Boris Red to use for textures (layer images).To use Boris Red without display 
or performance problems, Texture Memory must be at least 32MB. Texture Memory 
available is not the absolute of memory on your card, but rather the amount available to 
Boris Red.

•   Texture Dimension displays the maximum texture size that can be used with the video 
card.
Macintosh OS Version displays the installed version of the Macintosh OS (if you are 
running on a Macintosh system.) Macintosh users must have at least Macintosh OS 
10.2.6 installed to support OpenGL. 

OpenGL Errors
When the OpenGL Hardware Test is run, error messages may display if your system fails. 
These errors display as Hardware Status errors or Critical Testing errors. 

Hardware Status errors report the status of your current system setup against Boris Red’s 
recommended card manufacturer, model and driver. These errors do not prevent you from 
using OpenGL, they just warn that your specific system and setup may cause problems with 
OpenGL. Hardware Status errors can include messages such as insufficient available texture 
memory or reports that your card was not recognized by Boris Red’s internal hardware 
testing. When you receive a Hardware Status error, OpenGL is automatically disabled when 
you launch Boris Red. However, you can manually enable OpenGL in the Boris Red 
Preferences window. 

Critical Testing errors report errors that will not allow you to use OpenGL in Red. When you 
receive a Critical Testing error, OpenGL is automatically disabled when you launch Red. If you 
receive a Critical Testing error, you should not enable OpenGL or you may crash. Certain 
errors are influenced by the display properties set on your video card. The display property 

http://www.avid.com
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settings are card-driver specific. As a general rule, the display properties should be set to 32 
bits of color, with the depth buffer set to at least 16 bits. On many cards the OpenGL 
capabilities are reduced when higher display resolution and refresh rates are set.

Enabling OpenGL
You can enable OpenGL in the Preview menu or in the Preferences window.

•   To enable OpenGL in the Boris Red Preference window, choose Edit > Preferences 
(Windows) or Boris Red > Preferences (Macintosh). Click the Render Tab and select the 
Accelerated Draft Preview checkbox. Choose the appropriate choice from the OGL 
Acceleration menu. On, Max. texture caching provides the best performance and is the 
recommended setting.

•   To enable OpenGL in the Preview menu, choose Preview > Open GL Mode. Choose the 
appropriate choice from the submenu. On, Max. texture caching provides the best 
performance and is the recommended setting.

Troubleshooting OpenGL Issues
To toggle OpenGL off, use the keyboard shortcut Command or Control-[. To turn it back on, 
the keyboard shortcut Command-] (Macintosh) or Control-] (Windows). Menu choices also 
appear in the Preview menu and in the Preferences window. You can still use Boris Red 
without OpenGL or with an older card, you just won’t gain as much acceleration.

Display problems such as white, rainbow or garbage images in the Composite window may 
be related to OpenGL. If this occurs, open the Preference window. In the Render tab, change 
the OpenGL Acceleration menu to use less texture caching. Texture caching is used for 
textures (layer images) and is related to the amount of Texture memory on the video card. 
Display problems related to OpenGL will not affect your rendered effects.

NOTE: If you experience OpenGL problems, setting the OpenGL Acceleration menu to 
use less texture caching improves OpenGL reliability, although it lessens 
OpenGL performance.
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Displaying Frames on your External Monitor
Commands in the Preview menu allow you to set the video display. 

When Connect to External Monitor is chosen in the Preview menu, Preview to Monitor is 
enabled and the following three options in the menu become available:

•   When you choose Auto-Update Monitor from the Preview menu, every frame of your 
effect previews to the external video monitor. This allows you to drag the CTI in the 
timeline and view updating frames. The image displays on the external monitor, using the 
Resolution and Quality settings specified in the Composite window.

NOTE: Enabling Auto-Update Monitor slows Boris Red since every frame updates in 
the external monitor. Also, OpenGL Acceleration is disabled in the Composite 
window when you enable Auto-Update.

•   When you choose Display Frame on Monitor from the Preview menu or click the Display 
Frame to Monitor button in the upper-right corner of the Composite window, the current 
frame displays on the external monitor, using the Resolution and Quality settings 
specified in the Composite window. 

•   When you choose Display HQ Frame to Monitor from the Preview menu, the image 
displays on the external monitor, using Full Resolution and High Quality settings, 
regardless of the Resolution and Quality settings in the Composite window. 

Disconnecting Preview to Monitor (Standalone) 
When you relaunch Boris Red, the external monitor is not connected until you choose 
Connect to External Monitor in the Preview menu. 

Tips for Using the Preview to Monitor Feature (Standalone) 
•   Preview to Monitor automatically disconnects when you exit Boris Red. This means each 

time you launch Boris Red, you need to choose Preview > Connect to External Monitor in 
order to reconnect and see your image on the external monitor. 

•   Displaying images on an external monitor requires compressing and resizing the images. 
Boris Red may run slower if you have Auto Update enabled. Deselect Auto-Update Monitor 
in the Preview menu to remain connected to the external monitor but not automatically 
update frames. 
Manually update frames to your external monitor by choosing Preview > Display Frame 
to Monitor, or Preview > Display HQ Frame to Monitor, or by pressing the Display Frame 
to Monitor button on the upper-right corner of the Composite window. 
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Exporting to Flash
Boris Red exports Flash .swf files that are compliant with the Flash 5 architecture. If you are 
using QuickTime to preview your exported .swf files, you need a version of QuickTime that 
supports the Flash 5 format. The following effects are supported for exporting to Flash.

•   Text
•   Spline media
•   2D Charts (which consist of text and spline shapes)
Other bitmap elements such as video or still graphics can be included in the exported Flash 
file and will be JPEG-compressed. In the Export preferences you can set the quality of the 
JPEG compression. 

NOTE: When you export text to Flash, any texture that was applied to the text is 
ignored. Also, when you export text with a gradient fill to Flash, the resulting 
.swf file is blank.

Exporting as Flash
Boris Red allows you to export files in the Macromedia Flash (SWF) format. This feature 
allows you to export compositions as compact, vector-based files optimized for web viewing. 
For example, you could export a Type On effect to include on a web page.

The SWF format was designed primarily for animated 3D Line Art objects, so it works well 
when exporting settings that contain spline and text animations. Settings that contain video 
or animated bitmaps, however, generate rather large files. You might want to consider 
exporting such animations as a QuickTime or AVI file. 

There are some limitations with the Flash export feature. You cannot export 3D Extrusion 
tracks as Flash. Settings that contain the 3D Extrusion tracks export as a blank track. The 
Flash export feature does not support shadows or gradients used as Texture tracks. However, 
you can export a static gradient as a bitmap background. 

NOTE: To prepare to export to Flash, you should change any shape track containing 
EPS files, text, or Spline media to 3D Line Art shape. Because you cannot use 
the 3D Line Art shape with the Brush tool, you cannot export brush strokes as 
Flash.

To export a track as a Flash file:

1. Select the appropriate track in the timeline.

2. Choose File > Export > Flash.

A dialog box appears that allows you to name and save the file.




